[personal profile] abortrephrase
I have an AppleTV. It's on 192.168.1.42. My gateway is a RouterOS box. Among the routes out of my LAN that it knows is a VPN that terminates in the US.

I'd already been routing specific destination addresses down that VPN, so any attempt to hit Pandora would go that way and thus work. But this isn't really adequate for stuff like Hulu where it's a giant mess of Akamai-fu.

So.


/ip firewall mangle
add action=mark-routing chain=prerouting disabled=no new-routing-mark=usa \
passthrough=yes src-address=192.168.1.42

/ip route
add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=nycvpn routing-mark=\
usa scope=30 target-scope=10


And now any packet originating on 192.168.1.42 will appear to the outside world as though it came from a machine in New York City.

The RouterBox is dirt cheap. It's a quality bit of kit that can do most of the things you'd expect from a "real" Cisco router. This is just one of the things that makes it awesome.

(no subject)

Date: 2011-08-04 11:16 am (UTC)
cxcvi: Red cubes, sitting on a reflective surface, with a white background (Default)
From: [personal profile] cxcvi
That actually sounds quite interesting. Wonder if I'll remember it the next time I set up a computer network from scratch...

(no subject)

Date: 2011-08-04 11:20 am (UTC)
ideological_cuddle: (Default)
From: [personal profile] ideological_cuddle
The RB is so cheap, I added one to my existing home network. Mainly so I could join a little IPsec/IPIP VPN with a bunch of friends, but it does so many neat tricks...

Basically, if the Linux kernel can do it, so can this.

Profile

Abort, Rephrase, Ignore?

October 2011

S M T W T F S
       1
2 345678
9101112131415
16171819202122
23242526272829
3031     

Most Popular Tags

Page Summary

Style Credit

Expand Cut Tags

No cut tags