[personal profile] abortrephrase
I have an AppleTV. It's on 192.168.1.42. My gateway is a RouterOS box. Among the routes out of my LAN that it knows is a VPN that terminates in the US.

I'd already been routing specific destination addresses down that VPN, so any attempt to hit Pandora would go that way and thus work. But this isn't really adequate for stuff like Hulu where it's a giant mess of Akamai-fu.

So.


/ip firewall mangle
add action=mark-routing chain=prerouting disabled=no new-routing-mark=usa \
passthrough=yes src-address=192.168.1.42

/ip route
add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=nycvpn routing-mark=\
usa scope=30 target-scope=10


And now any packet originating on 192.168.1.42 will appear to the outside world as though it came from a machine in New York City.

The RouterBox is dirt cheap. It's a quality bit of kit that can do most of the things you'd expect from a "real" Cisco router. This is just one of the things that makes it awesome.
From:
Anonymous
OpenID
Identity URL: 
User
Account name:
Password:
If you don't have an account you can create one now.
Subject:
HTML doesn't work in the subject.

Message:

If you are unable to use this captcha for any reason, please contact us by email at support@dreamwidth.org


 
Notice: This account is set to log the IP addresses of everyone who comments.
Links will be displayed as unclickable URLs to help prevent spam.

Profile

Abort, Rephrase, Ignore?

October 2011

S M T W T F S
       1
2 345678
9101112131415
16171819202122
23242526272829
3031     

Most Popular Tags

Style Credit

Expand Cut Tags

No cut tags